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Introduction
This set of exercises is designed to provide basic instruction on how to configure SNAP and how
to use many of the model editing capabilities in SNAP. The following topics are covered:

• Editing an existing model in the Model Editor.

• Creating new component in a model.

• Connecting components using the connect tool.

• Duplicating components using copy/paste.

• Manipulating drawn components in a view.

• Importing view templates.

These exercises assumes you have properly installed the SNAP software along with the the 
following applications:

• The AptPlot plotting package. (http://www.aptplot.com)

• The jEdit editor. (http://www.jedit.org  )

• Adobe Acrobat Reader. (http://www.adobe.com  )

• TRACE Executable

• The following software will be needed for later exercises: 

Please refer to your system administrator or the installation instructions located on the SNAP 
website (http://www.nrcsnap.com) if you have any questions concerning installation.
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Exercise 1. Configuring SNAP
The following exercise provides a set of instructions for configuring a new SNAP installation for
this workshop on a Windows system. The SNAP runtime was designed to work with a minimal 
amount of configuration, therefore most options can be left at their default values. The following 
steps assume that SNAP has not been previously configured on the system and that all properties 
are currently at their default values.

1. Open the Configuration Tool by selecting All Programs → SNAP → Configuration 
Tool from the Start Menu.

2. Select your AptPlot executable by pressing the S button located to the right of the 
Plotting Tools property. 

This will open a file selection dialog. 

3. Navigate to the AptPlot installation directory and select the AptPlot.exe file located 
under the bin directory, then press the Open button.

Note: The AcGrace plotting software can also be used with SNAP. To use AcGrace 
under Windows, Cygwin's bin and usr\X11R6\bin directories must be included in your 
system path: (c:\cygwin\bin;c:\cygwin\usr\X11R6\bin;) In addition, an X11 server must 
be running.
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4. Select your jEdit installation folder by pressing the jEdit button ( ) to the right of the 
jEdit Executable property.

This will open a directory selection dialog. If jEdit is not installed, skip this step.

5. Navigate to and select your jEdit installation directory, then press the Open button.

A prompt will appear, indicating that the SNAP jEdit installation was successful.

6. Dismiss the prompt by pressing the OK button.

Note: Matlab can be configured for use as an external function calculation engine. 
This requires defining the location of the Matlab executable in the configuration tool. 
This is not required for this workshop.

7. Expand the Applications node in the tree on the left.

This will display the applications available for execution as part of a SNAP run. The 
applications currently displayed (if any) are those automatically defined as part of a 
SNAP installation. The next several steps will define the TRACE application used 
throughout these exercises.

8. Right-click on the Applications node and select New from the pop-up menu.

The Create Application dialog is displayed, listing the available application types.

9. Select TRACE from the list of applications and press the OK button.

A new, unspecified TRACE executable will be created for use in SNAP models. The new 
application should be selected, with its properties displayed on the right. If not, follow 
the next step.

10. Select the Unspecified TRACE application in the Applications list.

The properties to the right will change to reflect those of the selected application. 
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11. Enter an appropriate short name for the TRACE application's Name property. 

12. Enter a description for the TRACE executable by pressing the E button next to the 
Description property.

13. Press the S to the right of the Local Location property, located in the Application 
Locations group.

A file browser will appear. This dialog is used to select the location of the executable on 
the local machine.

14. Navigate to the location of the TRACE executable, select it in the file browser, then press
the Select button.

15. Save the configuration by either selecting File → Save All from the main menu or by 
pressing the Save button ( ) in the tool-bar.

16. Exit the Configuration Tool.
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Exercise 2. Editing an Existing Model
This exercise is designed to familiarize the analyst with the basic editing capabilities of the 
SNAP Model Editor using the TRACE plug-in. The following steps act as a guide through 
editing an existing TRACE model in SNAP. This exercise will cover a series of important topics 
including creating new components, editing component attributes, basic undo/redo functionality, 
and engineering units.

The exercise will take a simple stand pipe model, half the pipe length and add a crossflow 
connected valve so that the resulting model appears as displayed below:
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The first step is to open the ModelEditor application. Under Windows, select the “All Programs 
→ SNAP → Model Editor option from the Start menu. This will open the ModelEditor and 
display the welcome dialog shown below:

1. Select the Open a Model Document → Continue >> option.

A file selection dialog will appear that is used to select a model file to open.

2. Locate and select the standpipe model provided with this exercise and open the model. 
(SNAP_Exercises/StandPipe1.med)

3. From within the navigator select and expand the Hydraulic Components → Pipes 
categories and select Pipe 1. 

The TRACE plug-in includes a property editor for each component attribute. Many of 
the attribute editors provide convenience functions such as copy/paste and plotting table
data in addition to the basic data entry function. Note that the initial conditions property
editor indicates that it contains invalid cell initial conditions. Legionnaires 

4. Select the Show ASCII item from the right-click pop-up menu item of the Pipe's 
navigator node.

Each of the components in the TRACE plug-in provide a Show ASCII menu item which 
displays the input of the selected component. The ASCII view is automatically updated 
when any of the component's properties are modified. The ASCII view window 
highlights card numbers, comments, and unknown values in distinguishing colors.

5. Specify the model units by opening the right-click pop-up menu from the model node in 
the Navigator and selecting British from the Engineering Units menu.
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Notice that each of the attributes are automatically converted to the appropriate value 
in British units. The TRACE plug-in allows a user to specify the engineering units a 
model is defined in. For this exercise we will be describing each of the values in British 
units. 

6. From within Pipe 1's property view, locate and open the property editor associated with 
the Component Geometry attribute.

The pipe geometry editor provides a series of columns and tabs for defining Pipe 
geometry data. The dialog is divided into two main segments, a component view and the 
property table. Each row in the table corresponds to a cell or edge. Selecting a cell/edge
in the view will highlight the row in the table corresponding to the selected cell/junction.
Selecting a row in the table highlights the cell/edge the table cell represents. Many of 
the table editors in the TRACE plug-in provide column header tool-tips which can 
further describe the values being edited.

7. Set the Calculate option to Volume and highlight each of the length cells in the dialog.

Cell geometry in TRACE is defined by specifying any two of the Length, Area or Volume
properties. The third property is then calculated from the entered data.

8. Type in a length value of 0.3 ft and press Enter.

Note that the ASCII view updates when the value is modified. The last row in the 
geometry dialog displays the column totals for the volume and length data.

9. Undo the modifications made to Pipe 1's lengths by selecting the Undo Cell Geometry 
Edit option from the Model Editor's Edit menu.

Modifications performed in the Model editor can easily be undone and redone. This will 
update the editor and ASCII view to reflect the pipe a the length modifications were 
made.
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10. Verify that the ASCII view updates to reflect the undo.

11. Select the Redo Cell Geometry Edit option from the Model Editor's Edit menu.

12. Close the Component Geometry editor.

13. Select and open the editor associated with the Initial Conditions attribute.

This will display the dialog shown below. 

14. Click the Gas Volume Fraction entry for the first cell and enter 0.0. 

15. Highlight the first cell in the Gas Volume Fraction column and choose the right-click 
pop-up menu Copy item to place the value on the clipboard.

Most tables in SNAP will allow you to copy and paste data values to and from 
spreadsheets, tab-delimited ASCII files as well as between SNAP tables.

16. Using the mouse, click and highlight the Gas Volume Fraction for cell 2 then drag the 
pointer to the last cell so that all of the remaining void fraction values are selected. 

17. Right-click on the table to open the table pop-up menu and select the Paste item. 

The remainder of the table should now be filled and the ASCII view will automatically 
update to reflect these changes. 

18. Select the first cell in the Pressure column and hold the Shift key. 

19. While holding down the Shift key, scroll to and click the last cell in the table and type a 
pressure value of 515 psi.

The editor will automatically calculate and set the temperature values of the liquid and 
gas using the built in steam tables.
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Notice that the attribute editor for initial conditions now indicates “[Valid Conditions]”
have been entered.

20. In the same dialog, select the Edges tab.

21. Set all Liquid Velocity values to 0.88 ft/s by selecting the liquid mass flow for junction 
1 and dragging the cursor to the last junction to highlight all of the table cells and then 
entering the value 0.88 ft/s.

Notes:

The Shift and Control keys can be used to add contiguous ranges and individual cells to 
the current table selection, respectively. 

When pasting a single value into a table, all selected values will be updated.

When pasting a set of multiple values from a spreadsheet, values are updated in a one-to-
one manner until either the number of values contained on the clipboard or the end of the 
selection is reached. 

22. Close the dialog and the ASCII view.

In the next few step we will add a discharge valve and some interactive control system 
components to the model.

23. Locate the Hydraulic Components → Valves category in the Navigator.

24. Create a new valve by selecting New from the Valves right-click pop-up menu.

25. Set the following values in the provided Valve completion dialog and then press the OK 
button:

Hydraulic Diameter: 0.48 ft
Number of Cells: 0
Orientation: Horizontal

26. Set the valve Component Number to 51 in the property view.

27. Locate the view labeled “Default View” from the Navigator Views category and select 
Open from the view's right-click pop-up menu.

28. Drag the valve off the Navigator and to the right hand side of pipe 1 cell 19.

The next steps will use the connect tool to connect the inlet of the valve to the cross-flow of 
pipe 1 cell 19.

29. Select the connection tool  from the view tool-bar.

30. Click on the circle on the left side of the valve.

31. Click on the diamond on the right side of the next-to-last cell of the pipe.

Refer to the figure for the proper connecting point location. 
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The cursor will change to a target when the connect tool is selected.
When the cursor hovers over the connection point located at the inlet
of the valve a set of cross-hairs will appear in the target indicating
that a connection can be made from this point. 

Clicking the left mouse button while the cursor is on a
connection point will initiate a connection. A rubber band line is
created from the connection point to the cursor. A filled blue
circle will appear when the cursor hovers over a valid target
connection point.

Move the cursor to the target connection point and click the left
mouse button to create a connection.

Notes: 

While a connection is being made, left clicking anywhere other
than a valid connection point will create intermediate line
segments for the connection.

Right clicking while creating a connection will remove the last
intermediate line segment or will cancel the connection if there
are no intermediate segments. The escape key can also be used to
cancel a connection. 

Connections have a right-click pop-up menu that can be used to add or remove points, to 
remove the connection from the view (cut) or to delete the connection from the model.

32. Choose the Select tool  from the view tool-bar. 

33. Select the newly created drawn connection line in the view.

34. Set the target component theta Angle property to 0.0 deg.

35. Create a new Break from the Navigator and drag it onto the 2D view to the right of the 
valve.

36. Connect the valve outlet junction to the Break inlet junction using the connect tool.

37. Choose the Select tool  from the view tool-bar. 

38. Right click on the newly created Break drawing and set its Drawn Orientation to Right.

39. Select the valve in the navigator and locate the Valve Type attribute in the Property 
View.

40. Set the Valve Type to [1] Flow Area Fraction Table

41. Open the editor associated with the Valve's Component Geometry attribute.

42. Set the valve Flow Area to 0.05 ft2 and close the editor.

43. Set the following values in the Valve property view:
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Maximum Valve Rate:  1.0 (1/s)
Off Adjustment Rate: 0.0 (1/s)
Minimum Position: 0.0
Maximum Position: 1.0
Valve Flow Area:  0.05 ft2

Valve Hydro Diameter:  0.48 ft
Initial Flow Area Fraction:  0.0
Valve Stem Position: 0.0

44. Next select the Break attached to the valve component and specify the following values 
in the property view:

Component Number:  20
Length:  0.6 ft
Volume: 0.1086 ft3

Initial Gas Volume Fraction: 0.0
Initial Mixture Temperature: 470.0 F
Initial Pressure: 515.0 psi

The next steps will use the insert tool to create new interactive controls for the model. These 
controls will be used to initialize and change the liquid flow rate, the valve flow area, and the 
surface heat flux of the outside surface of the heat structure.

45. In the 2D view, select insertion tool  and expand the drop down menu to select 
“Control Systems → Control Blocks”.

This will define that the insert tool will create new control blocks. After clicking the 
mouse once, the mouse tool will automatically revert to the select tool.

Note: The component insertion tool is located within the 2D view tool-bar as a drop-
down menu. Selecting a component from the drop-down menu allows the user to create 
the specified component and place it in the 2D view. This method is an alternate to 
creating the component from the category New right-click menu items.

46. Click the mouse using the insert tool to the left of Pipe 1, below the Interactive TRACE 
Demo text label.
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47. Select type [-9] Interactive Variable in the provided completion dialog and press OK.

48. Verify that the Type of the Controller Block is [-9] Interactive and set the properties of 
the interactive variable as follows:

Control Block Name: heatflux
Variable Name: Heat Flux

49. Construct another Interactive variable using the 2D insertion tool, which will be used as 
the valve stem position controller.

50. Specify the following information for the newly constructed interactive variable:

Control Block Name:  valvepos
Minimum:  0.0
Maximum:  1.0
Constant 1:  0.0
Variable Name: Valve Area

51. Construct another Interactive variable using the 2D insertion tool, to serve as the inlet 
flow velocity controller.

52. Select the newly constructed interactive variable and specify the following information:

Control Block Name:  invel
Constant 1: 0.88
Variable Name: Inlet Vel

The next step is to connect the previously created interactive controllers to their associated 
hydraulic components.

53. Select Fill 11 and locate its Fill Table property.

54. Open the editor and set the Independent Variable to the invel interactive controller.

55. Press OK to close the dialog.

The connection between the fill and the interactive controller in the 2D view will be 
indicated with a green dotted line.

56. Next select the valve component and set its Valve Table Indep. Var. property to the 
valvepos interactive controller.

57. Locate and open the editor for the First Adjustment Table property in the valve 
property view.

58. Press the Add button twice to add two rows to the table.

59. Set the cells in the first row to 0.0, 0.0.

This tells the valve to set the flow area fraction to 0.0 when the interactive variable 
provides a 0.0 value.

60. Set the cells in the second row to 1.0, 1.0
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This tells the valve to set the flow area fraction to 1.0 when the interactive variable 
provides a 1.0 value.

61. Press the OK button to save the values and close the dialog.

62. Select Heat Structure 31 in the Navigator.

63. Open the editor for the Axial Nodes / Surface BCs property.

64. Select Axial Cells 5 through 20 in the Outer Surface Boundary Conditions column.

65. Set the Boundary Condition property to [10] Controlled Heat Flux.

66. Set the Control Signal property to the heatflux interactive controller.

Next we will configure the heat structure to reflect changes made to the pipe length and 
initialize its temperature values.

67. Select each of the cells in the Axial Cell column.

68. Set the Length property of the nodes to 0.3 ft.

This reflects the modification made in an earlier step to Pipe 1 where we cut the length 
of the nodes from 0.6 ft from 0.3 ft.

69. Press the OK button to accept the changes and close the dialog.

70. Open the Initial Temperature property editor.

71. Highlight all of the cells in the table and type in value 470.0 and press enter.

This will set the initial temperature of the radial nodes of the heat structure to 470.0 F

72. Verify each of the values are set to 470.0.

73. Press the OK button to accept the changes and close the dialog.

In the next few steps we will add some basic annotations to the view.

74. Select the “Annotation →  Text” item from the view insert tool drop-down menu.

75. Click on the view just below the heatflux interactive variable created earlier.

76. Enter “Heat Controller” as the Text property.

77. Set the Font to “Dialog, Bold, 12”  by selecting the bold 'A' character in the font 
selection editor.

78. Select the “Annotation →  Rectangle” item from the view tool-bar
drop-down menu.

79. Use the insert tool to surround the new text annotation and the control
component.

Note that the rectangle is drawn over the top of these items and prevents
them from being seen.

80. Open the right-click pop-up menu on the new Rectangle and select the 'To Back” option.
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81. Repeat this procedure to add labels and boxes around the Inlet Velocity Controller, and 
Valve Controller control systems we created earlier.

The resulting view should resemble the one shown below:
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Exercise 3. Working with Model Views
This exercise is designed to build upon the model created in Exercise 2, and continue introducing
model building elements of SNAP. This exercise will cover topics including copying and pasting 
components, creating small control networks, basic undo/redo functionality, and engineering 
units.

The exercise will take a simple stand pipe model, duplicate the pipe and insert the duplicated 
component between the existing pipe and the outlet. The resulting system will match the system 
displayed below:

1. If you do not have the model from Exercise 2 open, open the file 
SNAP_Exercises/StandPipe2.med included with these exercises.
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2. Expand the Views Navigator node. 

Models can contain any number of 2D views. These views are loaded and saved with the
model. Views contain 2D drawn representations of many types of model components and
provide tools to help describe those components. The views can contain annotations, 
background colors, grid, etc.. Views allow component searching using the binocular 
icon provided in the view tool-bar. Zoom options are available by selecting the 
magnifying glass icon or using the right-click menu.

In the next steps we will create a duplicate copy of the pipe component and a simple control 
system to generate a display value. 

3. Select the Hydraulic Components → Pipes → Pipe 1 node in the Navigator and select 
the Copy option from its right-click pop-up menu.

4. Choose the Paste Special option from the right-click pop-
up menu of the Pipes category node.

5. Select the Offset Component Numbers By option and set
the offset to 1.

The paste special dialog allows a user to create multiple
copies of the same component starting at a specific offset
with a specific number increment. This also allows users to
copy/paste model components within the same model or
into a separate model.

6. Press the OK button to paste the component. 

7. Locate the view labeled “Default View” and select Open
from the view's right-click pop-up menu.

Note: The view's pop-up menu also includes a print option.

8. Expand the Hydraulic Components category in the
Navigator and drag Pipe 2 onto the view just above Pipe 1.

All components which have a 2D representation can be dragged onto a 2D view. Only 
one instance of each component can exist in a view (no duplicates of the same 
component are allowed in the same view). Components which have connections to other 
components in that view will automatically draw those connections when they are 
inserted into the view.

9. Right-click on Pipe 2 in the view and select the Scale Drawing menu item.

10. Set the Length Scale Factor to 5.95, the Width Scale Factor to 10.0, and press the OK 
button.

11. Select the background of the 2D view to bring up the views properties.

12. Locate the Canvas Size property and re-dimension the views height to be 900 pixels.

This will increase the amount of vertical space we have available so that there is 
adequate space for adding and moving components in the view.
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13. Select the connection from the outlet of Pipe 1 to Break 21.

14. Select the Disconnect option from the right-click pop-up menu.

Note: The undo/redo functionality can be used to resolve any issues where a component 
or connection has been mistakenly added or removed.

15. Select the connection tool  from the view tool-bar and create a connection between the
inlet of Pipe 2 and the outlet of Pipe 1. 

16. Use the connection tool  to create a connection between the outlet of Pipe 2 and the 
inlet of Break 21.

17. Choose the Select tool  from the view tool-bar. 

18. Use the view's left-click rubber-band tool to select each of the display components which
are arranged vertically. (This does not include the valve or its connected time dependent 
volume)

19. With the components selected, open the view right-click pop-up menu and select the 
Align → Center item where the icon shows a vertical line.
This will cause the components to center around a common vertical axis.

In the next steps, the heat structure that was originally duplicated along with pipe 1 will be 
removed, and replaced with a new heatstructure.

20. In the Navigator select Heat Structure 32 and select Delete from the right-click pop-up 
menu.

Components which are deleted can be restored
using the undo functionality.

21. Select the Copy item from the right-click pop-up
menu of Heat Structure 31.

22. Select the Heat Structures Navigator category
node and select the Paste Special option.

23. Set the Offset Component Number property to 1
in the provided dialog, and press the OK button.

24. Select the newly created Heat Structure in the
Navigator.

25. Open the editor for the Axial Nodes / Surface
BCs property.

26. Select all of the cells in the Inner Surface
Boundary Conditions column and open the 
Hydraulic Cell property editor in the lower
property view.

27. Change the referenced pipe value to the newly created pipe by opening the editor next to 
the Hydraulic Component property and selecting pipe 2 from the list. 
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Once the Pipe has been selected as the Hydraulic
Component, two spinners will appear to allow the
selection of the range of hydraulic cells to map to
the selected Heat cells.

28. Press the OK button to save the value and close
the dialog.

29. Verify the Starting Cell is set to 1 and the 
Ending Cell is set to 20.

30. Press the OK button at the bottom of the Heat
Connections editor.

Next we will set the heatflux controller on the lower
portion of the pipe.

31. Select the first four axial cells in the Outer
Surface Boundary Conditions column.

32. Set the Boundary Condition property to 
[10] Controlled Heat Flux.

33. Set the Control Signal to the heatflux controller.

34. Select the last 4 axial cells (17-20).

35. Set the Boundary Condition property to [0] Constant Heat Flux.

36. Press the OK button to accept the changes and close the dialog. 

In the next steps a control block summer will be created to determine the pressure drop across the
two pipes. Two signal variables will be created signifying the pressures at opposite ends of the 
pipes. 

37. Using the insertion tool, select Control Systems → Signal Variables.

38. Insert the first signal variable on the view below the valve component.

39. Select type [21] Pressure in the provided completion dialog.

40. Insert the second signal variable directly below the last signal variable and again set the 
type to [21] Pressure in the provided completion dialog.

41. For the upper signal variable, open the editor for the Signal property.

42. Set the Hydraulic property to Pipe 1, the Cell to 1, and press the OK button.

43. For the lower signal variable, open the editor for the Signal property.

44. Set the Hydraulic property to Pipe 2, the Cell to 20, and press the OK button.

The signal variables will be supplied to a subtract block in order to determine the 
pressure drop across the pipes. 
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45. Using the insert tool drop-down menu, place a control block on the view to the right of 
the signal variables.

The placement should be similar to the following figure.

46. Select [54] Subtract when prompted  from the completion dialog. 

47. Set its Control Block Name property to deltaP.

48. Using the connect tool, connect the signal variables to the subtract block by connecting 
the upper signal variable to the upper connection point and the lower signal variable to 
the lower connection point.

49. Select the Annotation →  Text item from the view insert tool drop-down menu and 
click on the view just above the new control network.

50. Enter “Pipe Pressure Drop” as the Text property.

51. Set the Font to “Dialog, Bold, 12”  by selecting the bold 'A' character in the font 
selection editor.

52. Select the Annotation →  Rectangle item from the view tool-bar drop-down menu and 
use it to surround the new text annotation and the control network. 

53. Open the right-click pop-up menu on the new Rectangle and select the 'To Back” option.

In the next section we will add some red lines adjacent to the pipe to signify the regions where 
power is being added to the heat structure.

54. Select the Annotation → Line annotation from the view tool-bar drop down menu and 
place a vertical line along the left side of Pipe 1, starting at the fourth vertical level from 
the bottom and extending to the topmost level of Pipe 1.

55. Set the First Arrow Head and Second Arrow Head properties to None.

56. Set the Color property to 255,0,0.

57. Use the right-click Copy/Paste menu items to copy the line to the right hand side of the 
Pipe and verify that it is placed at the same vertical position. 

These lines are a simple indicator of where the heatstructure powers the Pipe. The 
TRACE plug-in supports a series of annotation objects including text, rectangle, 
polygon, ellipse, image, and line.
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58. Copy one of the lines created in the previous step to left hand hand of Pipe 2.

Position the line such that the top of the line begins at the bottom of the fourth cell from the 
top of the pipe and stretches to the bottom of the pipe.

59. Repeat these steps to place an annotation to the right-hand side of Pipe 2. 

60. Select the background of the view and open the right-click pop-up menu. Locate and 
select the Zoom option.

This opens the view zoom and scaling options pop-up dialog. This dialog allows 
controlling the zoom, the view size, and the view scaling factors in one convenient 
location.

61. Click on the red arrow ( ) to bring up the zoom shortcut pop-up menu.

62. Click the Fit to Window option from the zoom shortcut menu. 
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This option adjusts the zoom in a view to display all of the drawn components and 
annotations inside that view.

63. Select the background of the view and open the right-click pop-up menu, locate the 
Tools option and select Trim Excess Canvas.

Note: The Trim Excess Canvas option can be used to easily reduce the canvas size to be 
the bounds of the components contained in the view.

In the next few steps we will use component grouping to group up each of the control systems 
and their associated annotations.

64. Locate the Pipe Pressure Drop control system block in the view and use the right-click 
rubber-band select tool to highlight the rectangular annotation, text annotation, and 
components.

65. With each of the pressure drop components selected, open the right-click pop-up menu 
and choose the Group option.

66. Select the Pipe Pressure Drop group and move the block until it is above the valve.

Notice that component grouping locks each component into a visual group. The 
elements in the group cannot be selected individually unless the group is first broken. As
the group is moved, each of the items belonging to the group move with respect to their 
location within the group. Individual components can only be added to one group, 
although groups can be combined with other groups.

67. Select the individual controller block components and group them using the procedure 
defined above. 

The next few steps we will demonstrate additional view features.

68. In the property view of the Default View, locate the Display Icon attribute and select the
camera icon to grab a snapshot of the current state of the view.

69. Press the OK button to accept the default image size.

70. Create a new view by selecting the Views category node in the Navigator and selecting 
the New option from the right-click pop-up menu.
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71. Set the Name of the view to Embedded Views.

72. In the new view, select the Annotation → Views option from the view tool-bar drop-
down and left-click inside the view to insert an embedded view.

73. Select the “Default View” in the dialog which identifies the view to embed in our current
view and press the OK button.

74. Double-click on the embedded icon to switch to the Default View.

More than one embedded view can be placed within a view to provide convenient 
navigation between views.

75. Once again bring up the right-click pop-up menu for the Default View and locate the 
Export Image option. 

76. Select the Entire View option and choose JPEG Image.

Note:  Either the entire view or current perspective can be exported. The image exporter 
supports the following formats: JPEG, PDF, PNG, SVG, and TIFF. Additionally, the 
view can be exported to the system clipboard to paste the image into external 
applications such as MS Word.

77. Export the image as modelview.jpg using the default image settings.

Image size and scale can be modified by the dialog which is provided after a filename 
has been specified.

78. Open the exported image and verify that it is an accurate representation of the exported 
view. 

79. Select the File → Save As... option to save the model with a new filename and then 
close the model.
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Exercise 4. Model/Component Diff Viewer
This exercise will instruct the user on how to use the Model/Component differencing utility. The 
diff tool compares the ASCII output of model components. Comparisons can be made between 
components, subsystems, or models.

1. Open the sample TRACE model “SNAP_Exercises/StandPipe_Resource.med” 
provided with these exercises .

2. Open the sample TRACE model “SNAP_Exercises/StandPipe_Comparison.med” also 
provided with these exercises.

3. Right-click on the model node for 
StandPipe_Resource.med and select
the Select Left Side to Compare menu
item.

4. Right-click on the model node for 
StandPipe_Comparison.med and
select the Compare to unnamed 
option.

The left column includes each of the
components which are contained in the
selected Left model
(StandPipe_Resource.med). The right
column includes the components in the
selected right model (StandPipe_Comparison.med). The comparison column includes 
the status of each of the component diffs. In the case where a model component does not 
exist in the other model, the comparison column will display a Left/Right Side Only tag 
in blue font. Components which have no differences will be displayed as No Differences. 
The components that are different will display Show Differences in red. Clicking Show 
Differences will open the component comparison window.
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5. Left-click the Show Differences table cell for control block Subtract -4 (deltaP).

The component comparison window is displayed, as shown below. 

The Up and Down buttons (a.k.a. Next Difference and Previous Difference) provide a 
way of navigating through a series of differences. As each difference is encountered, the 
table at the bottom of the screen updates displaying the differences encountered at that 
line. The data is organized such that the left model ASCII is displayed above the right 
model ASCII. The characters in the lines which are different are shown in a red font.

6. Press the Next Difference button ( ) at the top of the component comparison dialog.

7. Visually identify the difference in the cbgain between the two components.

Note: Pressing the Export Diff Output button located at the top of the
component diff viewer will export the difference to an ASCII file.

8. Close the component diff viewer.

9. Select the Subtract -4 (deltaP) control block component in the left model column of the 
Multiple Component Comparison dialog.

10. Press the blue Up button at the top of the dialog.

The Multiple Component Comparison window allows a user to modify the alignment of 
the compared components. The up and down arrows will take the selected component 
and swap it with the component in the selected direction. Once a component has been 
swapped to a new comparison position, a new diff is automatically generated for the 
compared components. This allows comparing components of different types.

11. Left-click the Show Differences table cell for Subtract -4 (deltaP) vs Sum -5.

12. Visually identify the differences in the ASCII between the two components.

13. Close the component diff viewer and exit the Multiple Component Comparison dialog.

14. Select and expand the Hydraulic Components category contained in the 
StandPipe_Resource.med model navigator.

15. Expand the Pipes category and select Pipe 1.

16. Select Left Side to Compare from the pipe's right-click pop-up menu.
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17. With the same pipe selected, select Compare to Pipe 1 from the right-click pop-up 
menu.

Components which are compared to themselves keep a copy of the original component 
ASCII in the left hand side of the component comparison dialog. When one of the 
components attributes change, the comparison dialog will update to display the exact 
effect the modification had on the component ASCII. This allows a user to easily view 
what changes a modification will make to the original component ASCII.

18. Select Pipe 1 in the Navigator and open the editor associated with the Component 
Geometry attribute.

19. Change the Length of the first cell to “.2” ft and verify the component comparison dialog
updates to reflect the modification. 

20. Close the component comparison dialog and the geometry dialog.

21. Right-click Pipe 1 in the Navigator and select Left Side to Compare from the pop-up 
menu.

22. Right-click Pipe 2 in the Navigator and select Compare to Pipe 1 from the pop-up menu.

23. Visually verify that the component diff viewer provides a comparison of the selected 
components.

Note: In situations where a modification adds additional lines of input, gray lines are 
inserted to identify those values which do not exist in the original.

24. Close the two models opened for this exercise.
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Exercise 5. Working with View Templates
This exercise is designed to familiarize the analyst with importing existing models and View 
Templates. View Templates provide a means of saving a layout of a view that may then be 
applied to a similar model.

In this exercise the analyst will use a sample View Template to lay out an imported model.

1. Import the sample TRACE input deck standpipe_viewtemplate.inp provided with these 
exercises (SNAP_Exercises/standpipe_viewtemplate.inp) by using the “File → Import 
→ TRACE ASCII” menu item.

2. At the Create Views prompt, uncheck all check-boxes and press the OK button. 

The model will be imported without views.

3. Create a new empty View by right-clicking on the Views node in the Navigator and 
selecting the New menu item. 

This should create and open a new View with the name "unnamed" and display its 
properties in the Main Property View.

4. Open the view pop-up menu by clicking anywhere inside the empty view (the pop-up 
from the Navigator node does not contain the necessary menu item). 

5. Select "Tools→Import View Template" in the pop-up. 

6. At the file browser, select
the file standpipe.mvt
provided with these
exercises
(SNAP_Exercises/standpi
pe.mvt) and press Open. 

This will apply the
template to the view,
which should now appear
as shown below:

Note: To export a View Template
of an existing view, use the "Tools
→ Export View Template" item
off the right-click pop-up menu in
the View.
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Exercise 6. Resource Bundle Import/Export
The TRACE plug-in provides a series of features which facilitate the editing of input models. 
This exercise will familiarize the user with using the Resource Bundle feature to quickly modify 
a set of components outside of the Model Editor as ASCII and re-import the model without 
losing model data such as views, documentation, or numeric variables.

1. Open the sample TRACE deck SNAP_Exercises\StandPipe_Resource.med provided 
with these exercises by using the File → Open menu item.

2. Export the sample model as a resource bundle by selecting File → Export → ASCII Full
from the main menu.

3. Select the Include Resource Map check-box in the Export File selector. 

Note that the TRACE plug-in will prompt the user to save the current model before the 
resource export completes if the model has not yet been saved.

4. Export the resource model as: “standpipe_resources.inp”

5. Using jEdit, locate and open the exported resource model.

Notice that the file includes a section at the top for a numerics map. This allows user 
defined numeric variables to be reconstituted from ASCII resource import.
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6. Locate the Timestep Data section located at the end of the input deck.

7. Change the end time (tend) to “1200.0” and save the model.

8. Close jEdit.

9. In the model editor select File → Import → TRACE from the main menu and choose 
the file “standpipe_resources.inp” exported previously.

10. Press the Yes option when the plug-in asks whether to import the resource file.

The resource import allows the user to specify which resources to include from the 
resource file. This includes views, user-defined numerics, and model documentation.

11. Verify that each of the available options are selected in the dialog and press the OK 
button.

12. Right-click the Views category and select Open Views from the pop-up menu.

To speed the resource import process, imported 2D Views are not automatically opened.

13. Select the Model Options node in the Navigator.

14. Locate the Timestep Data property and open the associated editor.

15. Verify the End Time was updated to 1200.0 seconds.

16. Select File → Close All from the main menu.

17. Press the Discard All button.
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Exercise 7. Advanced 2D Drawing
The goal of this exercise is to demonstrate some of the features used to create larger and more 
complex nodalization views with the Model Editor. This process begins with Layers, to illustrate 
some of the ways layers can be used to organize large complex views. Afterward, the drawing 
capabilities of the Polygon bean are used to complete the illustration of the broken loop.

1. Open the file "SNAP_Exercises/TraceTypPWR.med" included with this exercise.

2. Open the Noding Diagram view by right-clicking the view's node in the Navigator and 
selecting the Open item.

This view contains a free form "nodalization view" of the full plant model. In 
appearance, it is similar to the full plant view in the Typical PWR animation mask. 
There are, however, a few significant differences that will be described later.

3. Open the Layer Manager by pressing the Layer Manager button ( ) on the view 
toolbar.

Layers provide a means of organizing the elements in a view. They can be locked and 
hidden independently. Locking a layer prevents selecting or clicking on the elements 
while the view is unlocked. Hiding a layer hides the elements in the layer from view.
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The Layer Manager is used to create, hide, and lock layers as well as to set the current 
layer. All elements added to a View are added to the current layer.

Layers are listed in alphabetical order following the Default layer, which appears first.
The Default layer is always available and contains all of the elements in the view that  
have not been moved to another layer.

4. Hide and show the Steam Generators layer by pressing the Hide/Show button ( ) to 
the left of the name.

Notice how the secondary side of the steam generators is hidden and shown (the text 
beans that still appear are part of the Annotations layer). This separation is both 
conceptual (primary vs. secondary side) and practical. Working with stacks of elements 
(polygons in this case) is easier when the elements below or above can be hidden. In 
this case, the secondary side of the steam generators can be hidden to make working 
with the u-tubes easier, or vice-versa.

5. Hide and show the Pipes layer by pressing the Hide/Show button ( ) to the left of the 
name.

Notice how the primary side of the steam generators (and most of the primary side of 
the plant) is hidden and shown.

6. Create a new layer by pressing the New Layer button ( ) at the top of the dialog.

Note that the new layer name (Layer 1) does not begin with a number (i.e. 6. Layer 1). 
The layers in this model were named starting with numbers to take advantage of the 
alphabetical sorting.

7. Remove the newly added layer Layer 1 by pressing the Remove button ( ) at the top 
of the dialog.

Note that the layer Layer 1 was removed and the layer above it (5. Annotations) was 
selected. Since the layer was empty it did not ask for a confirmation before removing 
the layer.

8. Select the Vessel layer by left-clicking on the layer name in the Layer Manager.
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9. Remove the Vessel layer by pressing the Remove button ( ) at the top of the dialog.

In this case a window is displayed asking what to do with the contents of the layer 
being removed. The options are to either move the contents into another layer or to 
remove the elements. A drop-down to the right has the list of layers the elements can be 
moved into. The initial choice is to move the elements into the Default layer.

10. Press OK to move the contents of the Vessel layer into the Default layer.

To the right of each layer name in the Layer Manager is the number of elements in that 
layer. Notice that the Default layer had 0 elements and now has 75.

11. Undo the removal of the Vessel layer by pressing the Undo button ( ) on the main 
toolbar.

Note that the Default layer again has 0 elements and the 75 elements have been 
returned to the Vessel layer.

12. Select the core section of the view by left-clicking above and to
the left of the core and dragging the rubber-band selection box to
the bottom right of the core.

Note that the each element in the core region is selected and
outlined in red. Any elements in a layer can be selected when the
layer is not locked or hidden.

13. Deselect the selected core elements by left-clicking on the empty
(gray) area around the core.

14. Lock the Vessel layer by pressing the Lock button ( ) to the left
of the name.

If the icon is red and appears open ( ) then the layer is not locked and pressing the 
button will lock the layer. If the icon is green and appears closed ( ) then it is locked 
and pressing the button will unlock the layer.

15. Try to select the core region again using rubber-band selection.

The core section can no longer be selected by rubber-band selection or single selection 
because the layer is locked. Locking a layer prevents it from being accidentally 
modified while working on other layers.
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The text in this region that can be selected is part of the Annotations layer. This can be 
easily seen by hiding and showing the Annotations layer.

16. Unlock the Vessel layer by pressing the Unlock button ( ) to the left of the name.

17. Create a new layer by pressing the New Layer button ( ) at the top of the dialog.

This will be the layer for the new parts created for this exercise, but first, it will need an
appropriate name.

18. Rename the new layer to "New Parts" by double-clicking on the name Layer 1 and 
entering the new name.

That gives it an appropriate name, but unless it is the Current layer the new parts won't
be automatically added to it.

19. Set the Vessel layer as the current layer by pressing the radio button to the left its 
Hide/Show button.

Notice that Vessel now appears as the current layer displayed in
the Layer Selector on the view toolbar to the right of the Layer
Manager button. The Layer Selector can be used to set the
Current layer directly, without opening the Layer Manager.

20. Set the newly created New Parts as the current layer by left-clicking on the Layer 
Selector and selecting “New Parts” from the list.

Also note that the list of layers also included a New entry. This is a quick way to create 
a new layer and set it as the Current layer.

Note: Additional information about Layers and the Layer Manager is available in the 
SNAP User's Manual by pressing the Help button at the bottom of the Layer Manager 
window.

That completes the Layers section. Next, we'll look at the Associated Component feature. Then, 
we'll create a few polygon beans to replace those that are missing in the view.

21. Lock the view by pressing the Lock button ( ) in the top left-hand corner of the view.

22. Zoom in on the broken loop (left) steam generator using either Ctrl + Mouse Wheel or 
the Zoom Tool.

23. Left-click on the white u-tubes labeled 204.

Nothing in the view will change to indicate where it was clicked, however, the main 
Properties View will show the properties of Pipe 204 (bsgtbs) and the Navigator will 
scroll to and select Pipe 204.
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24. Left-click on the blue area just inside or just
outside the blue u-tubes labeled 270.

Again, the view remains unchanged, but Pipe
270 will be selected in the Navigator and
displayed in the main Properties View. The
pipe is selected because the Polygon beans
representing the U-Tube and the surrounding
steam generator segment are associated with 
Pipe 204 and Pipe 270, respectively.

25. Double-click on the same area inside or outside
the u-tubes.

This opens a Mini-Navigator window for the
component associated with the Polygon.

26. Unlock the view by pressing the Unlock button ( ) in the top left-hand corner of the 
view.

27. Again, left-click on the u-tubes Polygon.

Because the view is unlocked, the polygon can be selected an its properties displayed in
the main Properties view. In this case, the interesting property is Associated 
Component, which is currently set to Pipe 204 (bsgtbs).

28. Left-click on the area just inside or just outside the blue u-tubes.

Notice that the area around and in between the u-tubes is made up of two Polygons 
(one white and one blue) with their Associated Component property set to 
Pipe 270 (bsgs rsr).

By using the Associated Component property, very detailed nodalization views can be 
designed that let the analyst work with a model in a format that's more familiar than the
automatic rendering provided by regular views.

Now that we see how drawing elements can be associated with components in the model, lets 
take a look at how to create some of the shapes required to build a detailed nodalization view.

29. Zoom out and examine the difference between the "Broken Loop" on the left and the 
"Intact Loop" on the right.

Notice that the broken loop accumulator (290) does not appear to have any water in it 
while the intact loop accumulator (190) does. This is a purely aesthetic difference, as 
the nodalization view does not directly reflect the conditions of the accumulator. 
However, it does make the drawing more distinct.

30. Zoom in on the Broken Loop accumulator 290.

31. Activate the Polygon insertion tool ( ) by selecting it from the Insert Menu to the 
right of the Connection Tool on the view toolbar.
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32. Start the accumulator polygon by clicking on the left side of the accumulator about even
with junction 292, then working counter-clock wise around the shape.

Follow the points in the given diagram. If you click in the
wrong place, right-click to remove the last point.

33. Left-click at each corner of the shape to add points.

Notice that each point will try to form a straight line from
the previous point.

34. Double-click on the first point to finish and close the
polygon as shown.

You'll notice that the existing accumulator's boundaries are slightly thicker than the 
new polygon. We'll fix that first so that the lines will be easier to match up.

35. In the Properties View, set the Outline Thickness property to “2”.

36. Set the Polygon's Fill Color property to a light blue, “121,184,246”.

Now it's time to round off the bottom to match the accumulator.

37. Right-click the bottom edge of the newly created polygon.

This will display the Polygon pop-up menu. At the bottom of this menu are several items
specific to the Polygon.

38. Select the Curve Segment item from the pop-up menu.

This will change the straight segment into a curved segment.
Curved segments have a start and end point (like straight
segments) but they also have two control points. These control
points are used to control the curve of the segment.

Note: The Curve Segment item will only be enabled when right-
clicking exactly on the line segment. If you miss, just click away
to close the pop-up menu and try again.

39. Drag the left control point straight down from the bottom left point to the location 
shown.
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The control point locations don't have to be perfect. They can always
be corrected later if the shape doesn't look quite right.

40. Drag the right control point straight down even with the left.

This will add a nice rounded shape to the bottom of the accumulator.

41. Use the arrow keys to move the new polygon directly on top of the
original.

The new polygon gives a sufficient hint that there is liquid in the
accumulator, but it could be better. It more resembles a pill than an
accumulator. It would look better without the black line between the
new and original polygons and maybe a wavy top to the liquid.

42. Right-click on the center of the top segment and select the Add Point
item to add a point to the top of the new polygon.

To get a good wavy look the line will need a center point for the two pairs of curves. 
But first, the top segment lines need to be hidden.

43. Right-click on each of the two top segments and select Curve Segment to curve the 
new segments.

44. Drag the left control point for each segment down and to the right.

45. Drag the right control point for each segment up and to the left.

That takes care of the wavy appearance of the top of the liquid. More ripples can be 
added by adding more points.

46. Right-click on each of the top segments and select Hide Segment to remove the outline 
from the new segments.

In this particular example the accumulator number (290) has been hidden by the water. 
As a final step, we'll pull that to the foreground.

47. Right-click the accumulator 290 text annotation and select the To Front item from the 
pop-up menu.

That completes the Intact Loop accumulator.
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